Automatically install any downloaded updates on Mac OS X

Check the recommended answer in this thread on superuser.com. For example, to autoinstall the updates at 8 PM daily, you basically need:

1.) Create /Library/LaunchDaemons/some.meaningful.name.plist

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>Label</key>
    <string>some.meaningful.name</string>
    <key>ProgramArguments</key>
    <array>
        <string>softwareupdate</string>
        <string>-i</string>
        <string>-a</string>
    </array>
    <key>StartCalendarInterval</key>
    <dict>
        <key>Hour</key>
        <integer>20</integer>
        <key>Minute</key>
        <integer>00</integer>
    </dict>
    <key>RunAtLoad</key>
    <false/>
    <key>KeepAlive</key>
    <false/>
</dict>
</plist>

2.) Execute the following in a terminal:

sudo launchctl load /Library/LaunchDaemons/some.meaningful.name.plist

Leave a Reply

Your email address will not be published. Required fields are marked *

× 8 = 56

This site uses Akismet to reduce spam. Learn how your comment data is processed.